Error with tbg_cli mailing:check_incoming

Get help using, installing and / or configuring The Bug Genie here
Post Reply
R4v3n
Posts: 15
Joined: Fri Apr 22, 2016 7:34 am

Error with tbg_cli mailing:check_incoming

Post by R4v3n » Thu May 12, 2016 8:45 am

Retrieving emails from the "Incoming email account" > "Check now" button is working.
But since I upgraded to 4.1, the "tbg_cli mailing:check_incoming" feature output this error :
Checking for emails ...

[myproject (bugs.myproject)] Processing (0 unprocessed)
[myproject (bugs.myproject)] Nothing to do for this account
The following notice has stopped further execution:

Undefined property: thebuggenie\modules\mailing\entities\IncomingEmailAccount::$connection
occured in
/my/path/thebuggenie-4.1.0/modules/mailing/entities/IncomingEmailAccount.php, line 295

Backtrace:
thebuggenie\core\framework\cli\Command::cliError()
/my/path/thebuggenie-4.1.0/core/framework/Context.php, line 232
thebuggenie\modules\mailing\entities\IncomingEmailAccount->disconnect()
/my/path/thebuggenie-4.1.0/modules/mailing/cli/CheckIncoming.php, line 57
thebuggenie\modules\mailing\cli\CheckIncoming->do_execute()
/my/path/thebuggenie-4.1.0/core/framework/cli/Command.php, line 54
thebuggenie\core\framework\cli\Command->execute()
/my/path/thebuggenie-4.1.0/tbg_cli, line 87

SQL queries:
(1) [0.8ms] from /my/path/thebuggenie-4.1.0/core/entities/tables/Scopes.php, line 76:
[...]
And a big stack of SQL queries at the end I spare you.

Any ideas ?

Thank you !
Last edited by R4v3n on Tue Jun 14, 2016 2:06 pm, edited 1 time in total.

R4v3n
Posts: 15
Joined: Fri Apr 22, 2016 7:34 am

Re: Error with tbg_cli mailing:check_incoming

Post by R4v3n » Thu Jun 02, 2016 4:01 pm

Nobody ? :(

wolfenstein87
Posts: 18
Joined: Tue Apr 19, 2016 2:43 pm

Re: Error with tbg_cli mailing:check_incoming

Post by wolfenstein87 » Mon Jun 06, 2016 9:42 pm

In my case, it was failing on my email servers certificate, which is at the bottom of the error message. Clicking the "Ignore certificate errors" in the projects email settings got rid of this issue.

R4v3n
Posts: 15
Joined: Fri Apr 22, 2016 7:34 am

Re: Error with tbg_cli mailing:check_incoming

Post by R4v3n » Tue Jun 14, 2016 3:01 pm

wolfenstein87 wrote:In my case, it was failing on my email servers certificate, which is at the bottom of the error message. Clicking the "Ignore certificate errors" in the projects email settings got rid of this issue.
Not better.
The fact is, from the web page /settings of any project, I can use the "check now" button successfully, it's only while triggering the "./tbg_cli mailing:check_incoming" command that I got the error.

R4v3n
Posts: 15
Joined: Fri Apr 22, 2016 7:34 am

Re: Error with tbg_cli mailing:check_incoming

Post by R4v3n » Mon Aug 08, 2016 2:36 pm

Nobody can help me or understand why it says :
"Undefined property: thebuggenie\modules\mailing\entities\IncomingEmailAccount::$connection" ?

R4v3n
Posts: 15
Joined: Fri Apr 22, 2016 7:34 am

Re: Error with tbg_cli mailing:check_incoming

Post by R4v3n » Mon Aug 08, 2016 3:02 pm

Ok just to let you know, there's a problem with the imap_expunge function from :
/modules/mailing/entities/IncomingEmailAccount.php (line 295).

I don't get this error anymore if I check the "KEEP EMAIL" option in each configured email addresses for bugs.

Then I got this error :

Code: Select all

PHP Fatal error:  Call to a member function getID() on a non-object in /my/path/to/thebuggenie-4.1.0/modules/mailing/Mailing.php on line 1274
Which is related to this part of the Mailing.php file :

Code: Select all

 if (framework\Context::getUser()->getID() != $current_user->getID())
                    framework\Context::switchUserContext($current_user);
The only way to make it works was to comment those 2 lines.

Then ./tbg_cli mailing:check_incoming is working like a charm.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest