slow search, probably JQuery`s issue

Get help using, installing and / or configuring The Bug Genie here
Post Reply
hamma
Posts: 3
Joined: Wed Feb 24, 2016 8:45 am

slow search, probably JQuery`s issue

Post by hamma » Wed Feb 24, 2016 9:01 am

I am using 4.1.0, very nice software but I am still working on speed issue.

Single search by a single user or just sorting of search results or reloading of them takes 10-12 seconds with only 250 issues (4-5 secs for 50 issues).
I can see that server`s CPU is used 100% for few seconds when I search.
It happens even when using TBG at server`s machine.

I tried many things like apache tuning, php tuning, cache tuning and more.
My guessing now that it is problem of JQuery or AJAX because page loads in 1.5 seconds (confirmed with Firebug) but displays in 10s and all this time I seeing indicator of loading, probably "search_results_loading_indicator".

What can I do? Switching JQuery.fx.off to true or changing JQuery.fx.interval from 13 to like 50-70 may help? (I trying these two but not succeed yet).
What else? Should I dig into TBG.Search.liveUpdate?

Any advice or opinion, please. Many thanks in advance.

hamma
Posts: 3
Joined: Wed Feb 24, 2016 8:45 am

Re: slow search, probably JQuery`s issue

Post by hamma » Thu Mar 03, 2016 8:44 am

If someone interested, I created a detailed topic at ServerFault.Com hoping for help.
Hope it would help someone else too.

http://serverfault.com/questions/761239 ... h-one-user

hamma
Posts: 3
Joined: Wed Feb 24, 2016 8:45 am

Re: slow search, probably JQuery`s issue

Post by hamma » Fri Mar 11, 2016 8:33 am

By the way, would somebody be so kind to share their loading speed of search page?
Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests