Page 1 of 1

4.1.13 Notification settings not saved

Posted: Tue Jan 17, 2017 9:43 am
by R4v3n
Another issue since I upgraded to 4.1.13 (and I guess related to not receving any email notification, even if the test email is working) is that TBG doesn't save my notification settings.

If I check all the 3 "AUTOMATICALLY SUBSCRIBE TO [...]" items, I click on save, got the green confirmation, then I refresh the page, the checkboxes are empty.

I got exactly the same behavior with the "NOTIFY WHEN [...]" items by checking "email" checkboxes.

No errors in apache logs.

Any ideas ?

Thanks !

Re: 4.1.13 Notification settings not saved

Posted: Tue Jan 17, 2017 11:15 pm
by zegenie
This is unfortunately a known issue with the 4.1.13 release. A fix is in the works.

Re: 4.1.13 Notification settings not saved

Posted: Wed Jan 18, 2017 8:55 am
by R4v3n
zegenie wrote:
Tue Jan 17, 2017 11:15 pm
This is unfortunately a known issue with the 4.1.13 release. A fix is in the works.
Thanks for the answer.
I though it was an issue in the 4.1.10 release and was fixed since.

Is there a way to enable those parameters directly in the DB ?
I guess my email notifications problems are directly linked to this issue ?

Thank you :)

Edit :
Even when setting to "1" for my user id those parameters in the "notificationsettings" table I've got no email notifs (noting outgoing in my mail.log too) :
notify_subscribed_issues
notify_subscribed_articles
subscribe_posted_updated_commented_issues
subscribe_created_updated_commented_articles
subscribe_new_issues_project
subscribe_new_articles_project

Re: 4.1.13 Notification settings not saved

Posted: Sat Jan 21, 2017 4:41 pm
by ramon.cutanda

Re: 4.1.13 Notification settings not saved

Posted: Fri Feb 24, 2017 5:17 pm
by matthias.sn
Tried the fix.
Page displays and saves now the settings.

But settings are not working for the alerts.

Re: 4.1.13 Notification settings not saved

Posted: Mon Feb 27, 2017 4:37 pm
by R4v3n
Tried the fix too.
Got new comment notification email, got an email for assigning an user, but nobody got an email for ticket creation.
So it's not perfect, but it's better, thanks.

Re: 4.1.13 Notification settings not saved

Posted: Mon Apr 17, 2017 8:37 pm
by ffabreti
Is this software still been evolved/updated?
I was thinking of using it on a production environment, but just got bitten by this issue (I am running 4.1.13).
last stable version according to http://www.thebuggenie.org/download is 4.1.0
This issue has like a year!

Re: 4.1.13 Notification settings not saved

Posted: Tue Apr 18, 2017 4:54 pm
by ramon.cutanda
The development continues on Git. You can check here the latest development changes:

https://github.com/thebuggenie/thebugge ... its/master

However, the latest is still 4.1.13, released on December 2016.

Regarding the notification bug, this fix worked for me:

https://github.com/thebuggenie/thebugge ... 956bbbcb0e

Bests,

Re: 4.1.13 Notification settings not saved

Posted: Wed Apr 19, 2017 10:07 am
by R4v3n
ffabreti wrote:
Mon Apr 17, 2017 8:37 pm
Is this software still been evolved/updated?
I was thinking of using it on a production environment, but just got bitten by this issue (I am running 4.1.13).
last stable version according to http://www.thebuggenie.org/download is 4.1.0
This issue has like a year!
yep :(