Google Authentication

Get help using, installing and / or configuring The Bug Genie here
Post Reply
JayGrayson
Posts: 2
Joined: Sat Aug 06, 2016 12:50 pm

Google Authentication

Post by JayGrayson » Sat Aug 06, 2016 12:59 pm

Maybe I am confused as to how it is supposed to work but, I cannot get any type of positive response from the OpenID when I attempt to use Google or Google Profile as the authentication method. This is a deal breaker for me since it is being used everywhere else in our environment. I have GADS and GAPS setup on our Active Directory since we have a Google Apps account. I am able to authenticate all of our other web services with Google. Using the LDAP Module for BugGenie is not an option since BugGenie is being hosted on an external hosting provider. I am not interested in punching a hole in the firewall to allow LDAP Authentication. When I attempt to authenticate with OpenID using Google or Google Profiles, I get:

Code: Select all

An error occurred in Projects
No OpenID Server found at https://www.google.com/accounts/o8/id

An unhandled exception occurred:
It seems that BugGenie is using an old method of contacting Google. Or am I doing something wrong?

Thanks for any help!

Jay

User avatar
zegenie
Site Admin
Posts: 41
Joined: Sun Jan 31, 2016 8:20 pm

Re: Google Authentication

Post by zegenie » Mon Aug 08, 2016 3:32 pm

You're right, Google deprecated support for this earlier this year and we've not been able to add support for the updated Google Auth yet. It's on our roadmap, but probably won't be in until 4.2. We've disabled Google openid auth in the latest 4.1.9 version as a result of this.

JayGrayson
Posts: 2
Joined: Sat Aug 06, 2016 12:50 pm

Re: Google Authentication

Post by JayGrayson » Mon Aug 08, 2016 3:35 pm

Ok. Thank you! I'll fiddle around with some things. If I get it working, I'll pass along the code.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests